| 1 | import { GraphQLScalarType, Kind } from 'graphql'; |
| 2 | |
| 3 | function stringScalar(name: |
| 4 | return new GraphQLScalarType |
| 5 | name, |
| 6 | description, |
| 7 | serialize: (value) |
| 8 | parseValue: (value) |
| 9 | parseLiteral: (ast) |
| 10 | }); |
| 11 | } |
| 12 | |
| 13 | export const URI = |
| 14 | 'URI', |
| 15 | 'An RFC 3986, RFC 3987, and RFC 6570 (level 4) compliant URI string.', |
| 16 | ); |
| 17 | export const HTML = |
| 18 | export const GitObjectID = |
| 19 | export const GitSSHRemote = |